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What Is Simulink Control Design?
(p. 1-2)

Introduction to the key features of
Simulink® Control Design

Purpose of Linearization (p. 1-3) Simplify system design and analysis
using linearized models

Using the GUI vs. Command-Line
Functions (p. 1-5)
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and command-line interfaces
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1 Introduction

What Is Simulink Control Design?
Simulink® Control Design provides tools for linearization and compensator
design for control systems and physical models in Simulink. Linearized
Simulink models often simplify compensator design and system analysis. This
is useful in many industries and applications, including

• Aerospace: flight control, guidance, navigation

• Automotive: cruise control, emissions control, transmission

• Equipment manufacturing: motors, disk drives, servos

Simulink Control Design works with the Simulink linearization engine and
the SISO Design Tool in the Control System Toolbox. Use Simulink Control
Design to

• Compute operating points of Simulink models using specifications or
simulation.

• Extract linear models from Simulink models.

• Tune compensator blocks in Simulink models with either single or
multi-loop configurations.

Simulink Control Design provides a graphical user interface (GUI) for
performing linearization and compensator design for Simulink models. This
chapter introduces a Quick Start guide for using this GUI. The remaining
chapters give more details on the linearization and compensator design tasks.
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Purpose of Linearization

Purpose of Linearization
Many common control system analysis and design methodologies require
linear, time-invariant models. However, control systems and physical models
created with Simulink are often nonlinear and time-varying. Linearization
is the approximation of a nonlinear system as a linear system, based on
the assumption that the system is almost linear within a certain range of
operation. With a linearized model you can

• Use the Control System Toolbox LTI Viewer to display and analyze the
dynamic behaviors of a model.

• Use the compensator design tools in the Control System Toolbox, Robust
Control Toolbox, and Model Predictive Control Toolbox to tune control
systems.

• Express a model as a transfer function, state space model, or zero-pole-gain
model.

• Determine the response of a model to arbitrary input signals.

A linearized model can provide a good approximation to a nonlinear system
when created and used carefully. Factors affecting the accuracy of the
approximation addressed in Chapter 2, “Beginning a Project in Simulink
Control Design” are

• Choice of operating points. See Chapter 3, “Specifying Operating Points”.

• Understanding the equations for the linearized model. See “What Is
Linearization?” on page 4-2.

• Controlling the effect of feedback loops. See “What Is Open-Loop Analysis?”
on page 4-9.

Role of Linearization in Compensator Design
Linearized models are especially important for designing compensators. Most
compensator design methodologies, such as Bode plots, require a linear plant
model. Since most real-world plant models are nonlinear, you must typically
linearize the system before you design the compensators for it. As a result,
the design of good compensators relies on a good linearization.
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1 Introduction

Although compensator design with Simulink Control Design automates the
process and linearizes the model for you, it is still important to understand
the fundamentals of creating an accurate linear model. Additionally, you
should always check that the compensator you designed for the linearized
system also works for the nonlinear system. Typically, the compensator works
well for the nonlinear system as long as the system does not vary widely
from the operating point.
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Using the GUI vs. Command-Line Functions

Using the GUI vs. Command-Line Functions
The Simulink Control Design GUI provides a graphical environment for
control system linearization and design. With the graphical environment, you
can easily inspect and analyze operating points and results of linearization.
In addition, you can save and restore settings as well as export results to the
MATLAB® workspace.

You can also linearize models using the command-line functions. With the
functions, you can automate many of your linearization tasks and perform
batch linearization, such as linearization of a system at several different
values of a parameter. There are no Simulink Control Design functions
specifically intended for designing compensators.
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1 Introduction

Using the Documentation

Expected Background
Users should be familiar with control systems design and analysis, and have
experience creating Simulink models. Familiarity with the Control System
Toolbox is also desirable.

How to Use This Guide
To quickly get started linearizing models with Simulink Control
Design, read “Linearization Quick Start” on page 1-8 for a brief overview
of the linearization process.

To quickly get started designing compensators with Simulink Control
Design, read “Compensator Design Quick Start” on page 1-10 for a brief
overview of the compensator design process.

If you are new to linearization, read “What Are Operating Points?” on
page 3-2 and “What Is Linearization?” on page 4-2. These sections introduce
linearization concepts that are important for accurate creation and use of
linearized models.

All users should read Chapter 4, “Linearizing Models” and Chapter 5,
“Designing Compensators”, which describe features and use of the Simulink
Control Design GUI.

To automate the linearization process, or perform batch linearization,
continue with “Linearizing Models Using Functions” in the Simulink Control
Design User’s Guide.

Online Documentation
Further documentation is available online or in the Help browser, including
the function and block references: “Functions — Alphabetical List” and
“Blocks — Alphabetical List”.
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Using the Documentation

Using Examples and Demos
The Simulink Control Design documentation uses several examples. You
can access these examples by typing

demo

at the MATLAB prompt and selecting Simulink Control Design under the
Simulink node. You can also access the examples by clicking the Demos tab
in the Help browser.

Related Products
The MathWorks provides several products that are especially relevant to
the kinds of tasks you can perform with Simulink Control Design. For
more information about these products, visit the MathWorks Web site at
http://www.mathworks.com/products/simcontrol/.
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1 Introduction

Linearization Quick Start
To quickly get started linearizing models with Simulink Control Design,
follow these steps. The documentation gives additional information for each
step in the process and describes the advanced functionality of the product.

1 Create or open a Simulink model and decide which portion of the model
you need to linearize. See “Creating or Opening a Simulink Model” on
page 2-2 for more information.

2 Open a linearization task for this model in the Control and Estimation
Tools Manager by selecting Tools > Control Design > Linear Analysis
from the model window. See “Beginning a New Linearization Task” on
page 2-7 for more information.

3 Select inputs and outputs for the linearized model by inserting linearization
points on the model diagram. To do this, right-click a signal line and select
Linearization Points, and then select either Input Point or Output
Point depending on whether you want the signal to be an input or output
for the linearized model. To remove the effect of feedback loops from
the linearized model, you can artificially open a loop by right-clicking
the signal line and selecting Linearization Points > Open Loop. See
“Configuring Inputs and Outputs for the Linearized Model” on page 4-5
for more information.

4 Specify the operating point for the linearized model in the Operating
Points node of the Control and Estimation Tools Manager. To compute a
steady-state operating point from state specifications, click the Compute
Operating Points tab and enter the specifications into the table, then
click Compute Operating Points. See Chapter 3, “Specifying Operating
Points” for more information and for methods of specifying alternative
operating points.

5 Linearize the model by first clicking the Operating Points tab within the
Linearization Task node and then selecting the appropriate operating
point from the list. To compute the linearized model, click the Linearize
Model button. See “Linearizing the Model” on page 4-14 for more
information.

6 Analyze the results with the Linearization Result pane and the
Linearization Inspector pane within the Model node. Create plots of
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Linearization Quick Start

the results with the Custom Views node. See “Analyzing the Results”
on page 4-17 for more information.

7 Export the linearized model to the MATLAB workspace by right-clicking
the Model node and selecting Export. See Chapter 6, “Saving and
Exporting Your Work”, for more information.
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1 Introduction

Compensator Design Quick Start
To quickly get started designing compensators with Simulink Control Design,
follow these steps. The documentation gives additional information for each
step in the process and describes the advanced functionality of the product.

1 Create or open a Simulink model. See “Creating or Opening a Simulink
Model” on page 2-2 for more information.

2 Open a compensator design task for this model by selecting
Tools > Control Design > Control Design from the model window.
The compensator design task opens in the Control and Estimation Tools
Manager. See “Beginning a Compensator Design Task” on page 5-4 for
more information.

3 Within the Tunable Blocks pane of the Simulink Compensator
Design Task node, click the Add Blocks button to select the blocks in
your model whose parameters you want to tune. These are typically the
compensators in your model. See “Picking Blocks to Tune” on page 5-6
for more information.

4 Within the Closed-Loop Signals pane, select the closed-loop system(s)
whose response(s) you want to design. A closed-loop system is defined by
an input point, such as a reference or disturbance signal, and an output
point, such as a measured output or actuator signal.

To define the closed-loop signals, insert linearization input and output
points on the model diagram. Right-click a signal line and select
Linearization Points, and then select either Input Point or Output
Point depending on whether you want the signal to be an input or output
for the closed-loop system. See “Selecting Closed-Loop Responses to
Design” on page 5-8 for more information.

5 Within the Operating Point pane, select the operating point to linearize
the model about when designing the compensators. To create a new
operating point, click the New Operating Point button. See Chapter 3,
“Specifying Operating Points” for more information and for methods of
specifying operating points.

6 Click the Tune Blocks button to open the Design Configuration Wizard
which guides you through the selection and configuration of the open- and
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Compensator Design Quick Start

closed-loop systems you want to tune, and the design and analysis plots
you want to use for this task. See “Creating a SISO Design Task” on page
5-14 for more information.

7 After completing the Design Configuration Wizard, a SISO Design Task
node is created in the Control and Estimation Tools Manager. The SISO
Design Task includes several tools for tuning the response of SISO
systems:

• A graphical editing environment in the SISO Design Tool window that
contains the design plots you configured in the Design Configuration
Wizard

• An LTI Viewer window where you can view the time and frequency
analysis plots that you configured in the Design Configuration Wizard

• A compensator editor where you can directly edit the block mask
parameters or the poles and zeros of compensators in your system

• A tool that automatically generates compensators using PID, internal
model control (IMC), or linear-quadratic-Gaussian (LQG) methods (uses
the Control System Toolbox)

• A response optimization tool that automatically tunes the system to
satisfy design requirements (available when you have the product
Simulink Response Optimization)

See “Completing the Design” on page 5-23 for more information on
designing compensators with the SISO Design Task node.

8 From the SISO Design Task node, click the Design node under
the Design History node. Then click the Update Simulink Block
Parameters button to write your tuned parameter values back to the
Simulink model. See “Writing the Design to the Simulink Model” on page
5-28 for more information.
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2

Beginning a Project in
Simulink Control Design

This chapter introduces a Simulink model of a magnetic ball system that the
remaining sections use to illustrate the features of Simulink Control Design.
A linearization task is created for the model in the Control and Estimation
Tools Manager, a graphical environment that manages the Simulink Control
Design linearization and compensator design projects. The key features of a
project in the Control and Estimation Tools Manager are also presented.

Creating or Opening a Simulink
Model (p. 2-2)

Opening the Simulink model of the
magnetic ball example

Beginning a New Linearization Task
(p. 2-7)

Introduction to the features of
the Control and Estimation Tools
Manager GUI



2 Beginning a Project in Simulink Control Design

Creating or Opening a Simulink Model
The first step in the linearization or compensator design process is to create
or open a Simulink model of your system. The model can have any number
of inputs and outputs (including none), and any number of states. The
model can include user-defined blocks or S-functions. Your model can involve
multiple compensators in addition to the plant, multiple feedback loops, and
any number of subsystems.

Example Model: The Magnetic Ball System
This section introduces an example model, the magnetic ball system, that the
remaining sections and chapters use to illustrate the process of linearizing a
model or designing a compensator with Simulink Control Design.

Magnetic Ball System
The electronic circuit in the following figure consists of a voltage source, a
resistor, and an inductor in the form of a tightly wound coil. An iron ball
beneath the inductor experiences a gravitational force as well as an induced
magnetic force (from the inductor) that opposes the gravitational force.
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Creating or Opening a Simulink Model

Model Equations
A differential equation for the force balance on the ball is given by

M
d h

dt
Mg

i
h

2

2

2
= − β

where M is the mass of the ball, h is the height (position) of the ball, g is the
acceleration due to gravity, i is the current, and β is a constant related to the
magnetic force experienced by the ball. This equation describes the height, h,
of the ball due to the unbalanced forces acting upon it.

The current in the circuit also varies with time and is given by the following
differential equation

L
di
dt

V iR= −
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2 Beginning a Project in Simulink Control Design

where L is the inductance of the coil, V is the voltage in the circuit, and R is
the resistance of the circuit.

The system of equations has three states:

h
dh
dt

i, ,

The system also has one input (V), and one output (h). It is a nonlinear system
due to the term in the equation involving the square of i and the inverse of h.

Due to its nonlinearity, you cannot analyze this system using methods
for linear-time-invariant (LTI) systems such as step response plots, bode
diagrams, and root-locus plots. However, you can linearize the model
with Simulink Control Design to approximate the nonlinear system as an
LTI system. Linearization also occurs automatically when designing a
compensator with Simulink Control Design. This linearized system can
then use the LTI Viewer for display and analysis and the SISO Design Tool
for compensator design. Refer to “Purpose of Linearization” on page 1-3 for
a discussion of the uses of linearized models and “Linearization of Simulink
Models” on page 4-3 for a discussion of the linearization process.

Opening the Model
To open the model for the magnetic ball example, type

magball

at the MATLAB prompt. The magnetic ball system opens in Simulink as
shown in this figure.
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Creating or Opening a Simulink Model

The magball model consists of

• The magnetic ball system itself, within the subsystem labeled Magnetic
Ball Plant.

• A Controller subsystem that controls the height of the ball by balancing
the forces acting on it.

• A reference signal that sets the desired height of the ball.

• A Scope block that displays the height of the ball as a function of time.

Double-click a block to view its contents. The Controller block contains a
zero-pole-gain model. The Magnetic Ball Plant block is shown in this figure.
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2 Beginning a Project in Simulink Control Design

The input to the Magnetic Ball Plant system, which is also the output of the
Controller subsystem, is the voltage, V. The output is the height of the ball,
h. The system contains three states within the three integrators: height,
dhdt, and Current.

Values of the parameters are given as M=0.1 kg, g=9.81 m/s2, R=2 Ohm,
L=0.02 H, and β=0.001.
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Beginning a New Linearization Task

Beginning a New Linearization Task
The Control and Estimation Tools Manager provides a graphical environment
for performing, and managing, control and estimation tasks such as
linearization and compensator design. Within this environment you can
create projects which can include several tasks, including tasks from Simulink
Parameter Estimation and the Model Predictive Control Toolbox, when they
are installed.

To open a new project within the Control and Estimation Tools Manager for
linearization of the magball model, select Tools > Control Design > Linear
Analysis from the magball window. The Control and Estimation Tools
Manager opens and creates a new linearization task, as shown in the
following figure.
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2 Beginning a Project in Simulink Control Design

The left pane of the Control and Estimation Tools Manager shows the project
tree, which contains all your current projects. At this stage you should have
just one project, Project - magball. Select a node within the tree to display
its contents in the pane on the right.
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• For information on the Operating Points node or the Operating Points
pane within the Linearization Task node, refer to Chapter 3, “Specifying
Operating Points”.

• For information on the Analysis I/Os pane within the Linearization
Task node, refer to “Configuring Inputs and Outputs for the Linearized
Model” on page 4-5.

• For information on the Linearization Results pane within the
Linearization Task node and inspecting linearization results, refer to
“Analyzing the Results” on page 4-17.

• For information on Custom Views, refer to “Analyzing the Results” on
page 4-17.
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3

Specifying Operating Points

The creation and selection of appropriate operating points are important
processes for both linearization and compensator design. This chapter guides
you through the process of creating operating points with Simulink Control
Design.

What Are Operating Points? (p. 3-2) Definitions and descriptions of the
operating point of a dynamic system,
including equilibrium, steady state,
and operating points

Creating Operating Points from
Specifications (p. 3-5)

Creating operating points in
Simulink Control Design from
partial information or specifications
of the system at the point of interest

Creating Operating Points from
Known Values (p. 3-11)

Creating operating points in
Simulink Control Design when you
know the values of states and inputs
at the point of interest

Creating Operating Points from
Simulation (p. 3-14)

Creating operating points in
Simulink Control Design by
simulating the system at the time of
interest

Exporting and Saving Operating
Points (p. 3-17)

Saving operating points for future
use



3 Specifying Operating Points

What Are Operating Points?
The operating point of a dynamic system defines its overall state at a given
time. For example, in a model of a car engine, variables such as engine speed,
throttle angle, engine temperature, and surrounding atmospheric conditions
typically describe the operating point. The level of the operating point affects
the system’s behavior. For example, the behavior of a car engine can vary
greatly when it operates at high or low elevations.

A linearized model is an approximation that is valid in a small region around
the operating point of the system. Near the operating point the approximation
will be good, while far away it will be poor. A linearized model of a car being
operated at 3000 ft. will be very accurate at elevations close to 3000 ft. but
less accurate as the car travels higher or lower.

The following figure shows a nonlinear function, y x= 2 , and a linear

function, y x= −2 1 . The linear function is an approximation to the nonlinear
function about the operating point x=1, y=1. Near this operating point, the
approximation is good. Away from this operating point, the approximation
is poor. The precise boundaries of this region are often somewhat arbitrary.
The following figure shows a possible region of good approximation for the

linearization of y x= 2 .
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When creating a linearized model from a Simulink model, the choice
of operating point is important as it will determine the accuracy of the
approximation. The choice of operating point is also important when designing
compensators with Simulink Control Design; a Simulink Compensator
Design Task uses linearization when analyzing a Simulink model. Choose
an operating point that is very close to the expected operating values of the
system. One way to do this is with an equilibrium operating point, described
in “Equilibrium Operating Points” on page 3-4.

Note The operating point consists of values for all the states in the model,
although only those states between the linearization points will be linearized.
This is because the whole model contributes to the operating point values of
the states/inputs/outputs of the portion of the model you are linearizing.
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Equilibrium Operating Points
An equilibrium operating point remains steady and constant with time; all
states in the model are at equilibrium. It is also known as a steady state or
trimmed operating point. For example, a car operating on cruise control on
a flat road maintains a constant speed. Its operating point is steady, or at
equilibrium, although a controller stabilizes the system.

A hanging pendulum provides an example of a stable equilibrium operating
point. When the pendulum hangs straight down, its position does not change
with time since it is at an equilibrium position. When its position deviates
slightly from this position, it always returns to the equilibrium; small changes
in the operating point do not cause the system to leave the region of good
approximation around the equilibrium value.

An example of an unstable equilibrium operating point is a pendulum that
points upward. As long as the pendulum points exactly upward, it is steady at
this equilibrium state. However, when the pendulum deviates slightly from
this state, it swings downward and the operating point leaves the region
around the equilibrium value.
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Creating Operating Points from Specifications
This section continues the magball example from “Beginning a New
Linearization Task” on page 2-7. At this stage in the example, a linearization
task has already been created for the model.

You can use Simulink Control Design to compute the operating point from
specifications when you only know partial or implicit information:

1 Create a new operating point by either

• Selecting the Operating Points node and then clicking the Compute
Operating Points tab

• Clicking the New Operating Point button on the Operating Points
pane of the Linearization Task node

2 From the Compute new operating points using list, select operating
specifications. The Control and Estimation Tools Manager window
should now resemble the following figure.
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3 Enter operating point specifications in the table, such as any known values
or constraints on signal values. Switch between states, inputs, and outputs
using the tabs on the left.

A suitable set of specifications for the magball model is shown in the
following figure. Note that in this case, the model does not contain any
root-level input or output ports and as a result the Inputs and Outputs
panes are empty. You can still constrain the output signal of any block
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by adding an Output Constraint linearization point to the model. See
“Constraining Outputs” in the Simulink Control Design User’s Guide for
information about adding an output constraint to the specifications for an
operating point.
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When you add states, inputs, or outputs to the model, or remove them from
the model, click the Sync with Model button to update the operating
point table to reflect these changes.

4 Click Compute Operating Points. Simulink Control Design finds an
operating point that closely matches the specifications and adds the new
operating point, labeled Operating Point, to the Operating Points node.
Note that some specifications, even values specified as Known, may not
be met exactly. Select the operating point in the project tree to view its
contents and assess the results.
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For information on options that you can set when finding operating points
from partial specifications, see “Changing Optimization Settings” in the
online Simulink Control Design User’s Guide.
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Note Inputs and outputs for the operating point are not the same as the
linearization input and output points, or analysis I/Os, used to define the
inputs and outputs of the linearized model. Inputs and outputs for operating
points are the inputs and outputs for the entire Simulink model, along with
any additional, user-defined output constraints.
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Creating Operating Points from Known Values
This section continues the magball example from “Creating Operating Points
from Specifications” on page 3-5. At this stage in the example, a linearization
task has already been created for the model, and a steady state operating
point has been computed from specifications.

When you know the values of all states and inputs at the operating point,
you can create a new operating point in the Control and Estimation Tools
Manager and manually edit the operating point values:

1 Select the Operating Points node in the left pane and then click the
Operating Points tab in the right pane.

2 Click the New button in the bottom-right corner to create a new operating
point under the Operating Points node. This new operating point is
called Default Operating Point (2).

3 View the details of Default Operating Point (2) by either

• Selecting it under the Operating Points node in the project tree

• Selecting it in the Operating Points pane of the Linearization Task
node, and then clicking View
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4 Edit the operating point by entering new values in the table. Switch
between state and input values using the tabs on the left.

For example, change the value of State-1 of Controller to -14 and the
value of Current to 7. Note that in this case, the model does not contain
any root-level input ports, and as a result the Inputs pane is empty.
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When you add states, inputs, or outputs to the model, or remove them from
the model, click the Sync with Model button to update the operating
point table to reflect these changes.

5 Rename the operating point by right-clicking Default Operating Point
(2) under the Operating Points node, selecting Rename, and entering a
new name in the dialog box.

For example, call this operating condition Known Operating Conditions.
The pane should now resemble the following figure.
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Creating Operating Points from Simulation
This section continues the magball example from “Creating Operating
Points from Known Values” on page 3-11. At this stage in the example, a
linearization task has already been created for the model, a steady state
operating point has been computed from specifications, and a completely
known operating point has been specified.

You can use Simulink Control Design to extract operating points from a
simulation of your model at specified times, such as when the simulation
reaches a steady state solution:

1 Create a new operating point from simulation by either

• Selecting the Operating Points node in the project tree, and then
clicking the Compute Operating Points tab

• Clicking the New Operating Point button on the Operating Points
pane of the Linearization Task node

2 From the Compute new operating points using list, select simulation
snapshots. The window should now resemble the following figure.
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3 Enter a vector of times in the Simulation snapshot times (sec) field. For
example, to compute operating points at t=1 and t=10, enter [1,10].

4 Click Compute Operating Points. Simulink Control Design simulates
the model, extracts operating points, labeled Operating Point at t=1 and
Operating Point at t=10, and adds them to the Operating Points node
in the project tree. Select an operating point to view its contents and assess
the results as shown in this figure.
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When you add states, inputs, or outputs to the model, or remove them from
the model, click the Sync with Model button to update the operating
point table to reflect these changes.
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Exporting and Saving Operating Points
You can export and save operating points that you created with Simulink
Control Design and then use them in a future Simulink Control Design task,
with command-line functions, or to initialize a Simulink model for simulation.
This section continues the magball example. At this stage in the example,
several operating points have been created.

In “Creating Operating Points from Specifications” on page 3-5 you computed
an operating point from specifications. To export it to the MATLAB workspace:

1 Under the Operating Points node in the Control and Estimation Tools
Manager, right-click the operating point labeled Operating Point that you
computed from specifications. Select Export to Workspace.

2 In the Export to Workspace dialog box

a Select Base Workspace to export the operating point to the MATLAB
workspace.

b Enter Operating_Point for the Variable Name parameter.

c Click OK to export the operating point and close the dialog box.

After you have exported the operating point to the MATLAB workspace,
you can save it in a MAT-file for later use. To save the operating point
Operating_Point in a file named magball_operating_points.mat, enter
the following command:

save magball_operating_point Operating_Point
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4

Linearizing Models

You can use the Simulink Control Design graphical user interface (GUI) to
linearize Simulink models. With this tool you can insert, inspect, and change
input and output points for linearization without adding blocks to the model
diagram and perform open-loop analysis without manually breaking signal
lines. Additionally, you can use the GUI to inspect results of the linearization
(block by block), export them to the MATLAB workspace, and display them in
the LTI Viewer. You can also save, reload, and compare linearization tasks
using alternative operating points and parameter values.

What Is Linearization? (p. 4-2) Factors affecting linearization of
Simulink models and an overview of
the linearization process

Configuring Inputs and Outputs for
the Linearized Model (p. 4-5)

Selecting and inspecting
linearization points, and performing
open-loop analysis

Linearizing the Model (p. 4-14) Running the linearization

Analyzing the Results (p. 4-17) Inspecting the linearization results
and displaying the results in the LTI
Viewer.
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What Is Linearization?
A linearized model is an approximation to a nonlinear system, which is valid
in a small region around the operating point of the system. Engineers often
use linearization in the design and analysis of control systems and physical
models.

The following figure shows a visual representation of a nonlinear system
as a block diagram. The diagram consists of an external input signal, u(t),
a measured output signal, y(t), and the nonlinear system that describes the
system’s states and its dynamic behavior, P.

You can also express a nonlinear system in terms of the state space equations

�x t f x t u t t

y t g x t u t t

( ) ( ), ( ),

( ) ( ), ( ),

= ( )
= ( )

where x(t) represents the system’s states, u(t) represents the inputs,
and y(t) represents the outputs. In these equations, the variables vary
continuously with time. Discrete-time and multi-rate models are discussed
in “Linearization of Discrete-Time Models” in the online documentation. A
linear time-invariant approximation to this nonlinear system is valid in a
region around the operating point at t=t0, x(t0)=x0, and u(t0)=u0. If the values
of the system’s states, x(t) and inputs, u(t) are close enough to the operating
point, the system will behave approximately linearly.
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Linearization of Simulink Models
Simulink uses a series of connected blocks to model physical systems and
control systems. Input and output signals connect the blocks, which represent
mathematical operations. The nonlinear system, P, in the previous figure,
represents a series of connected Simulink blocks.

Simulink linearizes both continuous and discrete-time nonlinear systems by
computing the state-space matrices of the linearized model, A, B, C, and D,
using one of the linearization algorithms described in “Understanding and
Controlling Results of Linearized Models” in the Simulink Control Design
User’s Guide.

Linearization Process Overview
The main steps to linearize a model using the Simulink Control Design GUI
are as follows:

1 Create or open a model. See “Creating or Opening a Simulink Model” on
page 2-2.

2 Create a new linearization task on the Control and Estimation Tools
Manager. See “Beginning a New Linearization Task” on page 2-7.

3 Specify an operating point for the model. See Chapter 3, “Specifying
Operating Points”.

4 Insert linearization input and output points in the model. See “Configuring
Inputs and Outputs for the Linearized Model” on page 4-5.

5 Linearize the model. See “Linearizing the Model” on page 4-14.

6 Inspect and validate the linearization. See “Analyzing the Results” on
page 4-17.

7 Save your project and export the results to the MATLAB Workspace. See
Chapter 6, “Saving and Exporting Your Work”.

The first three steps in this process were completed in the previous chapters.
This chapter continues the magball model example to give a detailed
discussion of the remaining steps.
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You can also use the Simulink Control Design command-line functions to
linearize a model. “Linearizing Models Using Functions” in the Simulink
Control Design User’s Guide gives detailed information on these functions.
For a discussion of the advantages and disadvantages of the GUI versus
the command-line interface, refer to “Using the GUI vs. Command-Line
Functions” on page 1-5.
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Configuring Inputs and Outputs for the Linearized Model
Before linearizing the model, you must first configure the model diagram. This
involves selecting input and output linearization points (also called analysis
I/Os), and then, if necessary, inserting open-loop points for performing
open-loop analysis. You can inspect the selected linearization points using the
Analysis I/Os pane within the Linearization Task node of the Control and
Estimation Tools Manager.

A linearization input point defines an input to the linearized model while
a linearization output point defines an output of the linearized model.
Additionally, when the linearized models are computed using numerical
perturbation, an input point is the point on the diagram where the small
perturbation to the input signal is introduced and an output point is the point
on the diagram where the small perturbation to the output signal is measured.
Linearization input and output points are not the same as operating points
which define the state of the model at the point of linearization.

The region between the input and output points defines the portion of the
model that you want to linearize, unless a feedback loop feeds the output
signal back into another section of the model. In some cases you might want
to remove the effect of a feedback signal. For example, you might want to
linearize only the plant model within in a feedback control loop. When such a
feedback loop is present, you can remove the effect of the loop by inserting an
open-loop point. Instructions for inserting open-loop points are in “Performing
Open-Loop Analysis” on page 4-9.

You can use Simulink Control Design to linearize the whole model, or
any blocks or subsystems within the model. To define the system you are
linearizing, place linearization points before and after it in the model diagram.

When you want to linearize a model that contains references to other models
using the Model block, you must use the numerical perturbation linearization
algorithm. The numerical perturbation algorithm numerically perturbs the
whole model and does not use linearization input and output points. See
“Numerical-Perturbation Linearization” in the Simulink Control Design
User’s Guide for more information.
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Note Linearization input and output points should not be confused with
Simulink Inport and Outport blocks. Input and output points define linear
analysis inputs and outputs, while Inport and Outport blocks define the
operating point of the system.

Inserting Linearization Points
This section continues the magball example from “Creating Operating Points
from Simulation” on page 3-14. At this stage in the example, a linearization
task has been created and operating points have been specified.

For a definition of linearization points, also known as analysis I/Os, see
“Configuring Inputs and Outputs for the Linearized Model” on page 4-5.

In the magnetic ball model, the nonlinearities are all contained within the
Magnetic Ball Plant. To linearize this subsystem:

1 Select the Linearization Task node within the Control and Estimation
Tools Manager.

2 On the magball model diagram, position the mouse on the signal line
between the Magnetic Ball Plant and the Controller. Right-click and select
Linearization Points > Input Point from the menu.

The model diagram now contains a small arrow pointing toward a circle
just above the signal line between the Controller and the Magnetic Ball
Plant, as in the following figure. This symbol indicates an input point for
linearization has been placed there.
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3 Right-click the signal line after the Magnetic Ball Plant and select
Linearization Points > Output Point from the menu.

A small arrow pointing away from a circle on the signal line appears after
the Magnetic Ball Plant indicating an output point for linearization has
been placed there. The diagram should now look like that in the following
figure.
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Note All linearization points are referenced to the output port of the
block the signal line originates from. For example, placing a linearization
point anywhere on the feedback loop in the figure above will result in a
linearization point at the output of the Magnetic Ball Plant block.

To remove a linearization point from the model, see “Removing Linearization
Points” on page 4-8. To inspect the linearization points in the Control and
Estimation Tools Manager, see “Inspecting Analysis I/Os” on page 4-12.

Removing Linearization Points
To remove a linearization point from a signal line in your model, repeat the
same process as for inserting a linearization point. For example, to remove an
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input point, right-click the signal line containing the input point and select
Linearization Points > Input Point from the menu. The input point
disappears from the diagram.

Performing Open-Loop Analysis
Due to the presence of feedback loops in a model, the input and output points
might not completely define the portion of the model you want to linearize.
In these cases, to remove the effect of signals feeding back into the portion of
the model you are linearizing, you might choose to insert an open-loop point.
“What Is Open-Loop Analysis?” on page 4-9 discusses the concepts behind
open-loop analysis. “Inserting Loop Openings” on page 4-11 continues the
magball example by inserting open-loop linearization points in the magball
model. “Open-Loop Analysis Using Functions” in the online documentation
gives methods for assigning open-loop points in Simulink models using
functions.

What Is Open-Loop Analysis?
Many control systems contain feedback loops. An example of such a system is
shown in this figure.

The model represented in this figure is at equilibrium. Consider linearizing
the plant, P, about this equilibrium operating point by changing the input
signal, U, by a small amount, u, and measuring the change in the output
signal, y. The portion of the system that you want to linearize is shown in
the following figure.
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However, due to the presence of the feedback loop, the change in the output
signal will feed back into the controller, C, and then into the plant. This affects
the behavior of the system you are linearizing. In fact, if C and P were linear,

the linearized model between U and Y would be
P s

C s P s
( )

( ) ( )1+ rather than P(s).

You could manually remove the feedback signal from the model in an attempt
to resolve this issue. However, as shown in the following figure, this changes
the operating point of the system since the error signal, E, is now equal to the
reference signal, R. Linearizing about this new operating point would change
the linearization results. Of course, this only makes a difference for nonlinear
models. When the model is already linear, it has the same form regardless
of the operating point.

When linearizing Simulink models, use the Simulink Control Design
capability to label an input or output point as open loop. Doing so ensures
that the output signal is not fed back into the model but keeps the operating
point the same. In other words, in the linear case, you would compute P(s)

rather than
P s

C s P s
( )

( ) ( )1+ . For more information, see “Performing Open-Loop
Analysis” on page 4-9.
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Inserting Loop Openings
This section continues the example from “Inserting Linearization Points” on
page 4-6. At this stage in the example, a linearization task has already been
created for the model, operating points have been specified, and linearization
input and output points have been inserted.

To linearize only the Magnetic Ball Plant, right-click the signal line containing
the output point and select Linearization Points > Open Loop. This
inserts a small x next to the output point in the diagram, representing a
loop opening.

"��������
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Note You do not need to place a loop opening in the same place as an input
or output point. For example, in the following figure the highlighted blocks
are included in the linearization. The loop opening is placed after the gain
on the outer feedback loop, which removes the effect of this loop from the
linearization. Placing a loop opening at the same place as the output point
would have removed the effect of the inner loop from the linearization as well.

Inspecting Analysis I/Os
This section continues the example from “Inserting Loop Openings” on page
4-11. At this stage in the example, a linearization task has already been
created for the model, operating points have been specified, linearization input
and output points have been inserted, and loop openings have been created.

To view the linearization points, click the Analysis I/Os tab in the
Linearization Task node in the Control and Estimation Tools Manager, as
shown in the following figure. Use this pane to inspect and make changes
to your linearization points.
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Note You cannot make changes to the Analysis I/Os or perform open-loop
analysis when you select Numerical Perturbation as the Linearization
Algorithm in the Linearization Task Options window (accessed by selecting
Tools > Options from the Control and Estimation Tools Manager window).
See “Changing Linearization Settings” in the online Simulink Control Design
User’s Guide for information.
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Linearizing the Model
This section continues the example from “Inspecting Analysis I/Os” on page
4-12. At this stage in the example, a linearization task has been created,
operating points have been specified, and linearization points have been
inserted.

After configuring the model and setting up the operating points, you are ready
to linearize the model.

Within the Linearization Task node, click the Operating Points tab. A list
of all available operating points for this project is shown. Select the operating
point(s) you want to use for the linearization. To linearize the magnetic ball
model around the operating point computed from partial specifications, select
that line in the list, as shown in this figure.
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To compute the linearized model:

1 In the menu to the right of the Linearize Model button, select from one of
the nine options for displaying the results of the linearization. Clear the
check box next to this menu when you do not want to display the results.

2 Click the Linearize Model button at the bottom of the pane. Simulink
Control Design computes the linearized model and displays it in the LTI
Viewer.
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The following figure shows the step response for the linearized magball model.

Using the LTI Viewer
To add characteristics such as settling time or peak response to your plot,
right-click anywhere in the plot area and select an option from the menu. Add
data markers by clicking the point you want to mark. In addition, you can
display up to six plots at one time. To change the number of plots, select
Edit > Plot Configurations. Export the linearized model to the workspace
by selecting File > Export. For more information, see LTI Viewer in the
Getting Started with the Control System Toolbox documentation.
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Analyzing the Results
To display all the linearization results from the current linearization task,
select the Linearization Task node and then click the Linearization
Results tab. At this stage you should have just one, Model, which also
appears as its own node in the project tree. To remove a linearization from
the Linearization Results list, select it and then click the Delete Model
button at the bottom of the pane.

To inspect and validate the linearization results, refer to “Validating the
Linearization” on page 4-17. To display and configure plots of the results,
refer to “Comparing the Results of Multiple Linearizations” on page 4-22. For
methods on simulating the linearized model for comparison with the original
model, refer to “Comparing the Linearized and Original Models” in the online
documentation.

Validating the Linearization
This section continues the magball example from “Linearizing the Model” on
page 4-14. At this stage in the example, a linearization task has been created,
operating points have been specified, linearization points have been inserted,
and a linearized model has been computed.

To display the Linearization Result pane, as shown in the following figure,
select the Model node in the project tree. To delete the linearization result,
right-click Model and select Delete from the menu. The Linearization
Result pane displays a mathematical representation of the linearized model.
By default it appears as a state space system and it displays the state space
matrices. However, within the pane you can choose to view the model as a
zero-pole-gain system or as a transfer function. You can also export the model
to the MATLAB workspace.
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Highlighting Blocks in the Linearization
To verify that the correct portion of the model was linearized, you can
highlight the blocks in the model that were used in the linearization.
To do this, right-click the Model node and select Highlight Blocks in

4-18



Analyzing the Results

Linearization. The following figure shows that the Magnetic Ball Plant
block, including all blocks within it, was used in the linearization.

To remove the highlighting, right-click the Model node and select Remove
Highlighting.

Note You cannot use the Highlight Blocks in Linearization or
Remove Highlighting option for models that are linearized with
numerical-perturbation linearization (when Numerical perturbation is
selected as the Linearization Algorithm parameter in the Linearization
Task Options window).

Inspecting the Linearization Block by Block
The Linearization Task includes a Linearization Inspector in which
you can inspect the results of the linearization block by block. This is useful
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when you want to verify that a block of interest, such as a block with a sharp
discontinuity, linearized as expected. To inspect the linearization of a block,
click the Linearization Inspector tab within the Model node. This pane
displays the linearization matrices of the individual blocks in the linearization
path, that is, the blocks between the input and output points.

This figure shows the results of the magnetic ball model in the Linearization
Inspector pane with Magnetic Ball Plant highlighted.
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Note The Linearization Inspector pane does not exist for models that
are linearized with numerical-perturbation linearization (when Numerical
perturbation is selected as the Linearization Algorithm parameter in
the Linearization Task Options window) as there are no individual block
linearizations to inspect.

Comparing the Results of Multiple Linearizations
This section continues the magball example from “Inspecting the Linearization
Block by Block” on page 4-19. At this stage in the example, a linearization
task has been created, operating points have been created, linearization points
have been inserted, and a linearized model has been computed and inspected.

The LTI Viewer automatically displays a Linearization Quick Plot of the
linearization results after the linearization. To create additional, customized
plots, especially for comparing multiple linearizations, right-click the Custom
Views node under the Linearization Task node and select Add View. A
new view, View1, is added to the Custom Views node. Select the View1
node to display the View Setup pane and set up this view.
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Example
Before configuring the View Setup pane for the magnetic ball system, run
another linearization of this model using the operating point labeled Known
Operating Conditions, that you computed in “Creating Operating Points
from Known Values” on page 3-11. This adds Model (2) to the Linearization
Task node.
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Configure View Setup as shown in the following figure:
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Click Display View to display the LTI Viewer, as shown in the following
figure:

Before proceeding to Chapter 5, “Designing Compensators”, close the Control
and Estimation Tools Manager and the magball model. You do not need to
save any projects or any changes to the model.
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5

Designing Compensators

You can use Simulink Control Design to tune and design compensators in a
Simulink model. You can design the response of both open- and closed-loop
systems in both single- and multi-loop configurations. Compensator design
with Simulink Control Design integrates the Simulink Control Design
linearization tools with the compensator design tools in the Control System
Toolbox and Simulink Response Optimization. This chapter continues the
magball example and designs a compensator to stabilize the system.

What Is Compensator Design?
(p. 5-3)

Description of concepts and
methodologies for compensator
design

Beginning a Compensator Design
Task (p. 5-4)

Creating a Compensator Design
Task in the Control and Estimation
Tools Manager

Picking Blocks to Tune (p. 5-6) Selecting the compensator blocks
that you want to tune in your design

Selecting Closed-Loop Responses to
Design (p. 5-8)

Specifying the closed-loop responses
whose behavior you want to design
or control

Selecting an Operating Point
(p. 5-11)

Choosing an operating point that the
model is linearized about during the
compensator design



5 Designing Compensators

Creating a SISO Design Task
(p. 5-14)

Setting up the SISO Design Tool
plots that you will use to tune the
response of the model

Completing the Design (p. 5-23) Finishing the compensator design
using graphical, automated, and
direct methods

5-2



What Is Compensator Design?

What Is Compensator Design?
Compensator design is the process of designing compensators for a control
system so that the system behaves in a desired way. Compensators in
Simulink models are represented by blocks such as Transfer function,
Zero-Pole-Gain, and PID blocks. These blocks can act as feedback controllers,
pre-filters, feedforward controllers, sensors, etc. Compensator design for
Simulink models can be as simple as adjusting gains in a one of these blocks,
or as complicated as adding, deleting, or moving poles and zeros in multiple
compensators over multiple feedback loops.

Compensator design methodologies often make use of tools such as Bode
diagrams, root-locus diagrams, or response plots. These tools require that
the plant model is linear; however, most real-world systems are nonlinear.
Simulink Control Design simplifies the task of designing compensators for
Simulink models by automatically linearizing the model before creating a
SISO Design Task in which you can edit and design the compensators using a
variety of tools.

Compensator design in the Control and Estimation Tools Manager involves
the following steps:

1 “Picking Blocks to Tune” on page 5-6

2 “Selecting Closed-Loop Responses to Design” on page 5-8

3 “Selecting an Operating Point” on page 5-11

4 “Creating a SISO Design Task” on page 5-14

5 “Completing the Design” on page 5-23
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Beginning a Compensator Design Task
This chapter continues the magball example from “Example Model: The
Magnetic Ball System” on page 2-2.

Before you begin this compensator design example, close the Control and
Estimation Tools Manager and the magball model, if you have them open, to
make sure you are working with a fresh version of the magball model. You do
not need to save any projects or any changes to the model.

To begin a new compensator design task for the magball model:

1 Enter magball at the MATLAB command line to open the magball model.

2 Select Tools > Control Design > Control Design from the magball
window.

The Control and Estimation Tools Manager opens and creates a new
compensator design task, as shown in the following figure.
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The project tree in the left pane of the Control and Estimation Tools Manager
now shows a Simulink Compensator Design Task node as part of
Project - magball in addition to the Operating Points node. You can select
a node within the tree to display its contents in the pane on the right.

• For information on the Tunable Blocks pane within the Simulink
Compensator Design Task node, refer to “Picking Blocks to Tune” on
page 5-6.

• For information on the Closed-Loop Signals pane within the Simulink
Compensator Design Task node, refer to “Selecting Closed-Loop
Responses to Design” on page 5-8.

• For information on the Operating Points node or the Operating Points
pane within the Simulink Compensator Design Task node, refer to
“Selecting an Operating Point” on page 5-11.
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Picking Blocks to Tune
This section continues the magball example from “Beginning a Compensator
Design Task” on page 5-4. At this stage in the example, a compensator design
task has been created.

In this step of the compensator design task, you will select the tunable blocks
in your model. The tunable blocks are those that you will tune in the SISO
Design Tool to achieve the desired response of your system. They are typically
the compensators in the system.

Blocks that are tunable in a Simulink Compensator Design Task include

• Gain

• PID

• LTI

• State-space (both continuous and discrete)

• Zero-Pole-Gain (both continuous and discrete)

• Transfer function (both continuous and discrete)

For the complete list of tunable blocks, see “What Blocks Are Tunable by
Simulink Control Design?” in the Simulink Control Design User’s Guide.

This example will tune the compensator black called Controller inside the
Controller subsystem. To add this as a tunable block for the magball model:

1 Select the Simulink Compensator Design Task node.

2 Within the Tunable Blocks pane, click the Select Blocks button. This
opens the Select Blocks to Tune dialog box.

3 Select the Controller subsystem in the left pane to display that subsystem’s
tunable blocks within the center pane. Within the center pane, select the
check box next to the Controller block’s name.
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Picking Blocks to Tune

4 Click OK to apply your selections and close the dialog box.
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Selecting Closed-Loop Responses to Design
This section continues the magball example from “Picking Blocks to Tune” on
page 5-6. At this stage in the example a compensator design task has been
created, and tunable blocks have been selected.

In this step of the compensator design task, you will select the closed loops
whose responses you want to design in your model. A closed-loop system is
defined by an input point, such as a reference or disturbance signal, and an
output point, such as a measured output or actuator signal. The Simulink
Compensator Design Task uses linearization points on the signal lines of
the model to determine the closed-loop systems. For more information on
linearization points, see “Configuring Inputs and Outputs for the Linearized
Model” on page 4-5.

In this example you will design the response of the closed-loop system from
the reference signal to the output of the plant model. To set up linearization
points to define this closed-loop system:

1 On the magball model diagram, position the mouse on the Reference
signal between the Desired Height block and the Sum block. Right-click
and select Linearization Points > Input Point from the menu to add
an input point.

2 Position the mouse on the signal line at the output of the Magnetic Ball
Plant block. Right-click and select Linearization Points > Output Point
from the menu to add an output point.
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The magball model should now appear as follows:
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Within the Control and Estimation Tools Manager, click the Closed-Loop
Signals tab of the Simulink Compensator Design Task node to view the
input and output points in the model.

Within this pane you can view the input and output signals in the model and
use the Active column to select the ones you want use to define closed-loop
systems for compensator design.
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Selecting an Operating Point
This section continues the magball example from “Selecting Closed-Loop
Responses to Design” on page 5-8. At this stage in the example, a compensator
design task has been created, tunable blocks have been selected, and
closed-loop signals have been selected.

In this step of the compensator design task, you will select the operating
point that you want to use in the compensator design. Simulink Control
Design uses the operating point when it linearizes the model before creating
a SISO Design Task. A compensator designed for the linearized model is
likely to control the behavior of the nonlinear model only in a small region
around the operating point that the model was linearized at. Therefore it is
important that the linearization of the model is accurate and the selection of
the operating point about which the system is linearized is an important step
in the compensator design process.

In Chapter 3, “Specifying Operating Points”, you created operating points
for this model, exported one to the MATLAB workspace, and saved it in a
MAT-file. This example imports the operating point that you saved. If you
did not already compute and save an operating point for the magball model,
you can import an operating point that was installed along with the Simulink
Control Design demos.

To import an operating point for compensator design:

1 Select the Operating Points node in the Control and Estimation Tools
Manager.

2 Click the Import button, in the bottom-right corner of the Control and
Estimation Tools Manager.

3 In the Operating Point Import dialog box, select MAT-file as the location
to import from.

4 Click Browse and locate the file magball_operating_point.mat that you
previously saved. If you did not previously save an operating point, browse to
matlabroot/toolbox/slcontrol/slctrldemos/magball_operating_point.mat.

5 Click Open to return to the Operating Point Import dialog box.
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The Operating Point Import dialog box now shows all the operating points
available within the selected MAT-file. In this case just a single operating
point is contained in the MAT-file.

6 Select this operating point and click Import to import it into the Control
and Estimation Tools Manager.

Click the Operating Points tab in the Simulink Compensator Design
Task node to view the list of operating points available for compensator
design. For this example, you should use the operating point that just
imported, called Operating_Point. Select this operating point in the list,
as shown below.
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Creating a SISO Design Task
This section continues the magball example from “Selecting an Operating
Point” on page 5-11. At this stage in the example, a compensator design task
has been created, and tunable blocks, closed-loop signals, and an operating
point have been selected.

In this step of the compensator design task, you will create and configure a
SISO Design Task in the Control and Estimation Tools Manager. The SISO
Design Task includes several tools for tuning the response of SISO systems:

• A graphical editing environment in the SISO Design Tool window that
contains design plots such as root-locus, and Bode diagrams

• An LTI Viewer window where you can view time and frequency analysis
plots of the system

• A compensator editor where you can directly edit the block mask
parameters or the poles and zeros of compensators in your system

• A tool that automatically generates compensators using PID, internal
model control (IMC), or linear-quadratic-Gaussian (LQG) methods (uses
the Control System Toolbox)

• A response optimization tool that automatically tunes the system to satisfy
design requirements (available when you have the product Simulink
Response Optimization)

The Design Configuration Wizard guides you through the selection of the
open- and closed-loop systems you want to design and the configuration of the
design and analysis plots you want to use in the SISO Design Task. To
launch the wizard, click the Tune Blocks button. The wizard opens in a
separate window.

The first page of the wizard provides an overview of the design configuration
process and lists some issues to consider when selecting design and analysis
plots. Click Next to continue to step 1 of the design configuration process on
the second page of the wizard.
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Configuring Design Plots
In step 1, select the open- and closed-loop systems that you want to design in
your model, and up to six corresponding design plots you want to use.

Open-loop design allows you to design the response of a closed feedback loop
in your model by artificially opening the loop and designing the response of
this open-loop system. The open-loop design plots use rules of linear control
theory to determine the dynamics of the closed-loop system from those of the
open-loop system. Open-loop design is typically used to tune compensators
that lie inside feedback loops.

Simulink Control Design creates a set of default open-loop systems for your
model, shown in the lower half of the wizard. To create these open-loop
systems, Simulink Control Design artificially opens the feedback loop at the
output signal of each tunable block (at the X in the following figure) and
unwraps the closed-loop system to create the corresponding open-loop system.
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The unwrapped open-loop system would appear as shown in the following
figure. This is the system shown in the open-loop design plots.

� � �

Note that elements that are outside the feedback loop, such as the prefilter F,
are not seen in the open-loop system.

In this example, you will tune the response of Open Loop 1 which is defined
by a loop opening at the output of the Controller block. This open-loop system
contains the plant model and the controller. To design this system, select Open
Loop 1 from the menu next to Plot 1 in the wizard.
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Next, select a design plot to use for this open-loop system. Design plots
are interactive plots within the SISO Design Tool. You can use them to
graphically tune parameters and manually move, add, or remove poles and
zeros of the tunable blocks to tune and design the dynamics of open- and
closed-loop systems in your model.

The available design plots are

• Open-loop design plots: root locus, Nichols, open-loop Bode

Use these plots to tune blocks that act as feedback elements.

• Closed-loop design plots: closed-loop Bode

Use this plot to tune blocks that act as feedforward or prefilter elements.

You can also use the design plots to specify stability and/or performance
requirements to use in using optimization-based automated tuning.

For this example, select Root Locus from the menu next to Plot 1 to use this
plot type as the design plot for Open Loop 1. Step 1 of the wizard should
now look as follows:

5-16



Creating a SISO Design Task

Click Next to proceed to step 2 of the wizard.

Configuring Analysis Plots
In this step, select the closed-loop responses that you want to view while
designing your model, and the corresponding analysis plots you want to use
to view them.

Analysis plots are plots that show the responses or dynamics of a closed or
open loop systems or tunable blocks in your model. Although you cannot
directly edit the analysis plots by graphically moving gains, poles, zeros, etc.,
changes that you make in the design plots, compensator editor, or automated
design tools will affect the responses in the analysis plots. Possible analysis
plots include

• Step response

• Impulse response

• Bode and Bode magnitude

• Nyquist

• Nichols

• Pole/Zero

You can use analysis plots to

• Analyze closed-loop, open-loop, and tuned block responses in your control
system.

• Define stability and performance requirements for optimization-based
automated tuning.

For this example, select Step from the menu for Plot 1 to create a step
response analysis plot.

Next, select the closed-loop system that you want to display in this plot. A
closed-loop system is a system that has not had any feedback loops opened for
open-loop design. It typically defines the system whose response you want
to control and it lies between the input and output signals of interest, for
example between a reference signal and the plant output signal.
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Simulink Control Design uses linearization input and output points that
you place on signal lines in your model to define closed-loop systems. The
closed-loop system includes all blocks in the path between the input and the
output.
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Simulink Control Design automatically displays a list of up to four closed-loop
systems in your model, based on the input and output points on the signal
lines. In this example, only one closed-loop system appears in the wizard, the
closed-loop from the Desired Height signal to the output of the Magnetic Ball
Plant Model, because the system only has one input and one output point. You
can add additional closed-loop responses, as well as open-loop and tunable
block responses. To add a new response, click the Add Responses button and
complete the Select a New Response to Analyze dialog box.

To display the current closed-loop system in the step response plot of Plot 1,
select the check box under Plot 1 to the left of the closed-loop system. Step 2
of the wizard should now looks as follows:
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Click Finish to complete the wizard and to create the SISO Design Task
underneath the Simulink Compensator Design Task node within the
Control and Estimation Tools Manager, as follows:
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The SISO Design Task also includes the design plots you configured in the
Design Configuration Wizard. They appear within the SISO Design Tool
window, as follows:
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In addition, the SISO Design Task also includes the analysis plots you
configured in the Design Configuration Wizard. They appear within the LTI
Viewer window, as follows:
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Completing the Design
This section continues the magball example from “Creating a SISO Design
Task” on page 5-14. At this stage in the example, a compensator design
task has been created, tunable blocks, closed-loop signals, and an operating
point have been selected, design and analysis plots have been created, and
a SISO Design Task node has been created in the Control and Estimation
Tools Manager.

In this step of the compensator design task, you will complete the design of
the compensator in the magball model, using the SISO Design Task node.
For a more detailed discussion of the SISO Design Task node, refer to the
Control System Toolbox documentation.

The SISO Design Task node contains five panes with various tools for
designing the compensators in your system.

• Architecture:

- Configure loops for multi-loop design by opening signals to remove the
effects of other feedback loops.

- Import compensators into your system.

- Convert the sample time of the system or switch between different
sample times to design different compensators.

• Compensator Editor:

- Directly edit the poles, zeros, and gains of the compensator.

- Add or remove poles and zeros to the compensators.

• Graphical Tuning:

- Configure design plots in the SISO Design Tool.

- Use design plots to graphically manipulate the response of the system.

• Analysis Plots:

- Configure analysis plots in the LTI Viewer.

- Use analysis plots to view the response of open- or closed-loop systems.
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• Automated Tuning: Design compensators using one of several automated
methods.

- Automatically generate compensators using PID, internal model control
(IMC), or linear-quadratic-Gaussian (LQG) methods (uses the Control
System Toolbox).

- Use a response optimization tool that automatically tunes the system
to satisfy design requirements (available when you have the Simulink
Response Optimization product).

You can use any of these design methods, or a combination of methods, to
design the compensators for your system. A suitable final design for the
Controller of the magball model is:

• Gain: -16000

• Integrator at the origin

• Complex zeros at -10±10i

• Real pole at -1000

With these settings, the root-locus diagram and step response plot should
appear as follows:
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Storing Designs
When designing a compensator within a Simulink Compensator Design
Task, you can store the current design so that you can continue designing and
still be able to return to a previously saved version of the design.

This section continues the example from “Completing the Design” on page
5-23. At this stage in the example a compensator has been designed to control
the system. To store the design within the SISO Design Task node:

1 Select the SISO Design Task node in the Control and Estimation Tools
Manager.

2 Underneath the SISO Design Task panes, click the Store Design button.
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This adds the current design to the Design History node. The default name
for the design is Design. To rename the design to something more meaningful:

1 Right-click the Design node underneath the Design History node.

2 Select Rename from the right-click menu.

3 Enter a name for your design. For this example, call the design Magball
Design.

The Control and Estimation Tools Manager should now appear as follows:
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Writing the Design to the Simulink Model
When designing a compensator within a Simulink Compensator Design
Task node, you can write the compensator design to the Simulink model.
This is useful when

• You want to see how the current design performs in the full nonlinear
model.

• You have completed the design and you want to update the model with the
newly designed parameters.

This section continues the example from “Storing Designs” on page 5-26. At
this stage in the example a compensator has been designed to control the
system and the design has been stored within the SISO Design Task node.
To write the stored design to the magball model:

1 Select the Magball Design node under the Design History node in the
Control and Estimation Tools Manager.

2 Click the Update Simulink Block Parameters button.

You can now simulate the magball model containing the newly designed
Controller block. After simulation, the Scope block of the magball model
should appear as follows:
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As you can see, the system is now stable and the height of the magnetic ball
settles at the desired height of 0.05 m.
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6

Saving and Exporting Your
Work

The Control and Estimation Tools Manager provides the capability to export
your linearization and compensator design results to the MATLAB workspace,
and to save and reopen your projects.

Saving Projects (p. 6-2) Saving projects in the Control and
Estimation Tools Manager

Opening Previously Saved Projects
(p. 6-3)

Loading projects in the Control and
Estimation Tools Manager

Exporting Results (p. 6-4) Exporting the results to the
MATLAB workspace



6 Saving and Exporting Your Work

Saving Projects
A Control and Estimation Tools Manager project can consist of multiple tasks
such as linearization, compensator design, and operating points tasks as
well as tasks from Simulink Parameter Estimation and the Model Predictive
Control Toolbox. Each task contains data, objects, and results for the analysis
of a particular model.

1 To save a project as a MAT-file, select File > Save from the Control and
Estimation Tools Manager window.

2 In the Save Projects dialog box, select one or more projects you want to
save. You can save multiple projects in one file. Click OK, and browse to
the folder where you want to save the project. Enter the project name,
and click Save.
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Opening Previously Saved Projects
1 To open previously saved projects, select File > Load from the Control and

Estimation Tools Manager window. This opens the Load Projects dialog box.

2 Choose a project-file by either browsing for the directory and file, or typing
the full path and filename in the Load from field. Project files are always
MAT-files. After you specify the file, the projects contained in this file
appear in the list. Select one or more projects in the list, and then click
OK. When a file contains multiple projects, you can choose to load them
all or just a few.
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Exporting Results
Using command-line functions, you can export operating points, compensator
designs, and results of a linearization to the MATLAB workspace for further
analysis. You can also export and restore linearization I/O settings.

This section includes the following topics:

• “Exporting Linearization Results” on page 6-4

• “Exporting Compensator Designs” on page 6-5

• “Exporting Operating Points” on page 6-6

• “Exporting and Restoring Linearization I/O Settings” on page 6-6

Exporting Linearization Results
To export linearization results and the corresponding operating points,
right-click the results node, Model, under the Linearization Task node
and select Export from the menu. In the Export To Workspace dialog box,
choose new names for the linearized model and operating point, or accept the
defaults, and then click OK.

The MATLAB workspace now contains two new objects, Model_op and
Model_sys. To see this, type

who

at the MATLAB prompt. This returns

Your variables are:

L Model_sys beta m
Model_op R g
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Alternatively, you can export the results to the MATLAB workspace by
selecting File > Export from the LTI Viewer window, or by clicking the
Export to Workspace button at the bottom of the Linearization Summary
pane within the Model node.

By right-clicking the results node, Model, you can also delete results.

Exporting Compensator Designs
To export a compensator design to the MATLAB workspace:

1 Select File > Export from the SISO Design Tool window.

2 Within the SISO Tool Export dialog box, use the Select design list to
choose the design you want to export.

3 In the list, select the compensators to export, and then click either Export
to Workspace or Export to Disk.
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Exporting Operating Points
After creating operating points using Simulink Control Design, you can use
the Export To Workspace dialog box to export them for use outside of the
Control and Estimation Tools Manager. You can use the exported operating
point to perform analysis at the MATLAB command line or to initialize a
model for simulation.

1 Under Select destination workspace, select either

• Base workspace to export the operating point to the MATLAB
workspace where you can use it with Simulink Control Design
command-line functions

• Model workspace to export the operating point to the Model workspace
where you can save it with the model for future use.

2 Enter a name for the exported operating point.

3 Select Use the operating point to initialize model when you want
to use the operating point values as initial conditions for the states and
inputs in the model. The initial values are automatically set in the
Data Import/Export pane of the Configuration Parameters dialog box.
Simulink uses these initial conditions when simulating the model.

Exporting and Restoring Linearization I/O Settings
To export linearization I/O settings to the MATLAB workspace, use the
getlinio function. You can save these settings using the save function. Use
them in a later session by reloading them with the load function. Upload
them to the model diagram with the setlinio function.

For more information, see the function reference pages for getlinio and
setlinio.
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Use this list to find examples in the documentation.



A Examples

Linearization Example Using the Graphical Interface
“Example Model: The Magnetic Ball System” on page 2-2
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